System

Config

Installer

InstallationReport

Summary

Etch

BL20p G3

RC1 netboot/i386

Worked

BL25p G1

BL35p G1

BL40p G1

BL45p G1

BL460c G1

RC1 netboot/amd64

#398981

Worked

BL465c G1

BL480c G1

BL485c G1

DL140 G3

SATA Hot Plug

2.6.18-based daily

Works 99% perfectly with 2007.01.16 - PS2 is not detected but everything else works (including USB) so this isn't a big issue. Test machine has SmartArray E200 RAID controller

DL140 G3

SAS Hot Plug

2.6.18-based daily

PS2 is not detected but everything else works (including USB) so this isn't a big issue (but cannot use KVM). Test machine has LSI SAS RAID controller.

DL145 G1

IDE

Etch Beta 3 netboot/amd64

#384238

DL145 G3

SATA

4.0r0 netinst CD

#421646

DL320 G4

SATA

20070208 daily build

#410336

Worked

DL360 G5

Etch Beta 3 netinst/amd64

#384202

Etch Beta 3 issues fixed in daily builds

DL360 G5

SAS

4.0r0 netinst CD

DL365 G1

Network

debootstrap

Installed from an Ubuntu CD. Had to manually install the HP Array Configuration Utility CLI for Linux from HP's website, and its needed librairy, to configure the disk arrays, which were perfectly detected, but was unable to install Grub, had to go for lilo.

DL380 G1

SCSI

Etch Beta 3 netinst/i386

Unable to get access Integrated Smart Array RAID volume. Probably the same problem seen here for fedora and in debian in bug #380272. Works fine with Sarge netinst.

DL380 G4

SCSI

Etch Beta 3 netinst/i386

#383544

DL380 G5

SAS

etch4.0/i386

Worked. It's possible to install HP official software hpacucli, hpadu, hpasm, cmanic and cpqacuxe officialy supported only for 3.1 Sarge. Don't work for me hprsm, hpsmh. Also possible to install the opensource array monitoring tool cpqarrayd and array-info.

DL385 G2

amd64 daily (2006.11.30)

#401150

Worked

DL580 G4

SAS

DL585 G1

SCSI

DL585 G2

RC1 netboot/amd64

#398992

Worked

ML110 G3

SATA

etch rc1/i386

Used software RAID, default intallation worked just fine. However, "vga=791" must be appended to kernel line, otherwise no consoles will be spawn.

Network

Debian Etch 4.0

Failed

Broadcom network card no longer supported by new 'free' Tigon3 drivers.

Network

Lenny

#507502

ML110 G4

SATA

20061121/i386

Didn't work with lvm root and LILO, using cciss driver with hardware RAID1

20070127/i386

worked fine.

20070217/amd64

#411621

No key input is avaiable after showing 1st dialog on VGA console. However install with serial (console=ttyS0 option) was success. It also works with an USB keyboard.

Debian Etch 4.0

Worked. Kernel 2.6.18-4-686. Sotware RAID during install on /, /home and swap. Network card supported natively. VESA driver only for xorg.

ML150 G3

SATA

amd64 (2007.09.14)

Worked with hardware RAID1.

ML310 G2

SATA

Debian Etch 4.0

worked

ML310 G3

+smartarray 641

etch rc1/i386

worked

Onboard SATA

20070208 daily

worked

ML310 G5

SATA

Debian Etch 4.0

worked. Integrated RAID Controler is SataRaid and at this time HP does not provide software RAID drivers. You must use SoftwareRAID.

ML320 G4

ML330 G3

SCSI/SmartArray 641

etch4.0/i386

default installation worked just fine (used GRUB and cciss for hardware RAID-1)

ML350 G5

SAS/HP Smart array E200i

etch4.0/amd64

worked

ML370 G1

SCSI/SmartArray

Worked, use Alien to install HPASM

ML370 G3

SCSI/SmartArray

netinst RC2 20070317

#415963

Worked, besides some general D-I issues that have nothing to do with the hardware

ML370 G5

ML570 G4

ML110 G5

etch40r3/amd64 (netinst)

Worked except network card. You can find working compiled tg3 kernel module and source code here.

Sarge

BL20pG3

SCSI

31r0a/i386

GRUB fails under linux26, use LILO

31r0a/amd64

GRUB and LILO fail

HPDE 20060905/i386

(./)

HPDE 20060815/amd64

(./)

BL25pG1

SCSI

31r0a/i386

GRUB fails under linux26, use LILO

31r0a/amd64

GRUB and LILO fail

HPDE 20060905/i386

(./)

HPDE 20060815/amd64

(./)

BL460c

SCSI

31r0a/i386

Missing storage/network drivers

31r0a/amd64

Missing storage/network drivers

HPDE 20061023/i386

(./)

HPDE 20061023/amd64

(./)

DL320G4

SATA

31r0a/i386

Missing SATA driver (ahci) - NIC driver too old (tg3)

31r0a/amd64

HPDE 20060905/i386

HPDE 20060815/amd64

DL360G4

SCSI

31r0a/i386

GRUB fails under linux26, use LILO

31r0a/amd64

GRUB and LILO fail

HPDE 20060905/i386

(./)

HPDE 20060815/amd64

(./)

DL380G1

SCSI

31r0a/i386

(./)

DL380 G2

SCSI

31r4/i386

(./) Initially GRUB seems to fail but can work. See notes below.

DL380G4

SCSI

31r0a/i386

GRUB fails under linux26, use LILO

31r0a/amd64

GRUB and LILO fail

HPDE 20061106/i386

(./)

HPDE 20061106/amd64

(./)

DL380G5

SAS

31r0a/i386

cciss driver too old, missing bnx2 driver for onboard nic

31r0a/amd64

HPDE 20061106/i386

(./)

HPDE 20061106/amd64

(./)

DL580G4

SCSI

31r0a/i386

cciss driver too old, missing bnx2 driver for onboard nic

31r0a/amd64

HPDE 20061027/i386

(./)

HPDE 20061023/amd64

need to drop to shell to load cciss driver

ML110 G4

SATA

3.1r4/amd64

kernel panic while initial boot (...seems normal to me, all ML110 G4 are intel based)

ML310 G3

SCSI

31r0a/i386

31r0a/amd64

HPDE 20070111/i386

(./)

HPDE 20061130/amd64

SATA

31r0a/i386

Needs newer ata_piix driver

31r0a/amd64

HPDE 20070111/i386

HPDE 20061130/amd64

ML115 G5

SATA2

CD1 4.0_r4 Built with jigdo

(./)

MyWiki: hp (last edited 2009-09-06 02:50:34 by localhost)